Friday , January 19 2018

Outlook Web App X-OWA-Error ExAssertException

Once installing Exchange 2016 Cu8 on Windows Server 2012 R2 gave error on OWA.

ECP will work if administrator doesn’t have a mailbox. else even ecp will throw the same error.

image

An unexpected error occurred and your request couldn’t be handled.
X-ClientId: F554643C29C44C22B59A1DF6E706EB91
request-id bd391bdf-5057-4d0e-8a4d-c5a4f42f22d2
X-OWA-Error Microsoft.Exchange.Diagnostics.ExAssertException
X-OWA-Version 15.1.1415.2
X-FEServer EXCH2016
X-BEServer EXCH2016

Search for Event 2004 to make sure you are having issues with the auth certificate-

Log Name:      Application
Source:        MSExchange OAuth
Event ID:      2004
Task Category: Configuration
Level:         Warning
Computer:      EXCH2016.careexchange.in
Description:
Unable to find the certificate with thumbprint A9BBA1727F285CD86EB5785DF47C0A19DA997280 in the current computer or the certificate is missing private key. The certificate is needed to sign the outgoing token.

Solution –

  • Creating a new Exch Auth Certificate.  Resolved the issue.

Ran below , Saw Auth certificate missing.

Get-ExchangeCertificate (Get-AuthConfig).CurrentCertificateThumbprint


Created a new certificate . Change to your default domain on the end of the command.

New-ExchangeCertificate -KeySize 2048 -PrivateKeyExportable $true -SubjectName "cn=Microsoft Exchange Server Auth Certificate" -FriendlyName "Microsoft Exchange Server Auth Certificate" -DomainName "careexchange.in"

Say no to Replace SMTP Certificate.

image

Run

Set-AuthConfig –PublishCertificate
Set-AuthConfig –ClearPreviousCertificate

Then run

Get-ExchangeCertificate (Get-AuthConfig).CurrentCertificateThumbprint

verified auth certificate created successfully.  Do iis reset.  wait for few hours if its a large environment. it should resolve the same.

image

Run below if still issue persists.

  • Locate bin folder and run updatecas.ps1 and updateConfigfile.ps1 resolved for few others.

image

Other things i have tried –

  • Took Backup – Tried Removing msExchCanaryData0/1/2. No luck

image

  • Uninstall and re install the server. No Luck

About Satheshwaran Manoharan

Satheshwaran Manoharan is an Microsoft Exchange Server MVP , Publisher of CareExchange.in
Supporting/Deploying/Designing Microsoft Exchange for some years.
Extensive experience on Microsoft Technologies.

Check Also

Optimize Antispam Settings in Office 365

Lets see how to optimize anti spam settings in office 365. Anti spam settings can ...

3 comments

  1. I am having the similar issue on the newly installed exchange 2016 cu8 , did you found any solution or is the bug with the CU8 release ?

    Since CU8 was just released 2 weeks back and not many users have had a chance to test it.

    I am planning to install CU7, could you please let me know if this issue is not present in CU7?

  2. i have the same X-OWA-Error error, but the instruction is not help me/ install was new, not update.

  3. Same here, have tried this and still doesn’t work. Fresh Server 2016, Fresh Exchange 2016, following installation processes published on TechNet. Do Microsoft actually have any testers? Because surely it should work out of the box?

Leave a Reply

Your email address will not be published.