Saturday , February 24 2018

How to recreate System Mailbox , FederatedEmail & DiscoverySearchMailbox in Exchange 2010

When we recreate — System Mailbox , FederatedEmail & DiscoverySearchMailbox in Exchange 2010 ?

  • DC crashes
  • If the Default Database is Deleted these maiboxes will go Orphaned
  • System mailboxes go Corrupted

You Could See these  (System Mailbox , FederatedEmail & DiscoverySearchMailbox) in Active Directory Users Container  by Default

System mailboxes are created by Exchange in the root domain of the Active Directory forest during installation. Users or administrators can’t log on to these mailboxes. System mailboxes are created for Exchange 2010 features such as message approval and Multi-Mailbox Search. This table lists information about system mailboxes as they’re displayed in Active Directory.

 

How to Verify these mailboxes are available and its active or not

Running in Exhcange Management Shell

Get-mailbox -arbitration

Should Show up SystemMailbox and FederatedEmail

If your not Seeing this , It means they are not enabled

Now Let us learn how to recreate them and Enable them

For Example I would Delete this Mailboxes from Users Container – in Active Directory Users and Computers

Now We need the Setup CD inorder to recreate them  “Same Version of Setup ”

Open Command Prompt

Browsed into the Setup location , Run

Setup.com /prepareAd

This would Create System Mailboxes , FederatedEmail & DiscoverySearchMailbox

Running

Setup.com /Preparead 

It should create them .But Until you Enable them, They won’t work

Now we got to Collect the SystemMailboxe and FederatedEmail and DiscoverySearchMailbox Exact GUID names inorder to Enable them

Now I have the values my my Environment

For Example –

System Mailbox GUID values

SystemMailbox{1f05a927-6a9b-4101-abd2-70838d0c8e86}
SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}

FederatedEmail GUID values

FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042

DiscoverySearchMailbox GUID values
DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}

Now We Got to Enable them –  (Real time you got to use your own GUID value)

Enabling System Mailboxes

Enable-Mailbox –Arbitration "SystemMailbox{Guid Value1}"
Enable-Mailbox –Arbitration "SystemMailbox{Guid Value2}"
Enable-Mailbox –Arbitration "FederatedEmail.Guid Value"
Enable-Mailbox - Discovery "DiscoverySearchMailbox {Guid Value}"

For Example I ran-

Enable-Mailbox –Arbitration "SystemMailbox{1f05a927-6a9b-4101-abd2-70838d0c8e86}"
Enable-Mailbox –Arbitration "SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"
Enable-Mailbox –Arbitration "FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042"
Enable-Mailbox - Discovery "DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}"

Now to Verify If you Did the Right thing

Running this – It should show up your System Mailboxes , FederatedEmail

Great !!

You learnt how to recreate System Mailbox , FederatedEmail & DiscoverySearchMailbox in Exchange 2010 Server

About Satheshwaran Manoharan

Satheshwaran Manoharan is an Microsoft Exchange Server MVP , Publisher of CareExchange.in
Supporting/Deploying/Designing Microsoft Exchange for some years.
Extensive experience on Microsoft Technologies.

Check Also

SQL 2008 R2 In place Upgrade to SQL 2014

I have a SCCM Database server running Windows Server 2012 R2 with SQL 2008 R2 ...

65 comments

  1. Awsome info and straight to the point. I am not sure if this is really the best place to ask but do you folks have any thoughts on where to get some professional writers? Thank you 🙂

  2. This is the turn How to recreate System Mailbox , FederatedEmail & DiscoverySearchMailbox in Exchange 2010 | careexchange.in blog for anyone who wants to attempt out out nearly this subject. You note so much its nearly exhausting to represent with you (not that I really would want…HaHa). You definitely put a new protract on a subject thats been inscribed nearly for geezerhood. Precise foul, just major!

  3. Good site! I really love how it is simple on my eyes and the data are well written. I am wondering how I might be notified whenever a new post has been made. I have subscribed to your RSS which must do the trick! Have a great day!

  4. I view something truly interesting about your weblog so I saved to fav.

  5. Very interesting info !Perfect just what I was searching for!

  6. I consider something really interesting about your web site so I bookmarked .

  7. is there any effects if i move these accounts to another OU in active directory ?

  8. Very interesting topic , regards for posting .

  9. I visited multiple websites however the audio feature for audio songs existing
    at this site is in fact marvelous.

  10. Hello I am so grateful I found your site, I really found
    you by mistake, while I was researching on Askjeeve for something else, Anyhow I
    am here now and would just like to say thanks
    for a marvelous post and a all round thrilling blog (I also love the theme/design),
    I don’t have time to read through it all at the
    moment but I have bookmarked it and also added your RSS feeds, so when I have time
    I will be back to read more, Please do keep up the
    superb b.

  11. It’s remarkable for me to have a website, which is good designed for my know-how. thanks admin

  12. Thank you for detailed explanation. It worked for me.

  13. I really like it whenever people get together and share thoughts.

    Great site, continue the good work!

  14. Is this workaround applicable if the arbitration mailboxes are corrupted and in inconsistent state?

  15. So very clear and concise!! This helped me out big time! Thank you for taking the time!

  16. Tthank you, help me after a Exchange server crash.

  17. Just finished installing exchange 2010 along side exchange 2003. created a test user on 2010. This user can send to users on 2003 and outside but can not receive from 2003 nor from outside. Please help.

  18. Thanks a lot. And I wish you have been the best in your way of Exchange engineer))

  19. Thank you so much for the great and easy explanation. We migrated from 2007 to 2010 a while ago and never used Discovery Search Mailbox, I tried to use it two days ago and I got an error saying it’s deleted, I checked it, it’s there, but when I run Exchange Powershell it’s shown as UserMailBox instead of DiscoveryMailBox, even though it’s shown in Exchange Console as DiscoveryMailBox.

    Please, help.
    Thanks!!!

  20. Thank you so much for the great and easy explanation. We migrated from 2007 to 2010 a while ago and never used Discovery Search Mailbox, I tried to use it two days ago and I got an error saying it’s deleted, I checked it, it’s there, but when I run Exchange Powershell it’s shown as UserMailBox instead of DiscoveryMailBox, even though it’s shown in Exchange Console as DiscoveryMailBox. How to fix this issue?

    Please, help.
    Thanks!!!

  21. Good day.
    We have lost our 3 system mailboxes on Exch 2010. Running setup.com/PrepareAD runs fine and finishes without error, but NO accounts are created.
    We installed the 1st Exch 2010 server on version of plain Exch 2010. Then we loaded SP1, then Sp2 and SP3.
    I am running the setup.com/PrepareAD from the SP3 DVD Microsoft disc.

    Should I run it from the original Exch 2010 version we used to install the system ?

  22. Hello, please tell me, these arbitration mailboxes exists on all exchange databases or exists in the root domain for all?

  23. Satheshwaran Manoharan, your documents always help me alot, recently my admin delete unintentionally deleted artibation mailboxes actual i have separate database for such mailboxes and that drive format by my admin, after that OAB is not working correctly as well as we are unable to search users in Lync so what i believer that the reason behind all such issue. we have such system account in AD but their mailboxes are not available so do i only need to run enable command from exchange shell. we are using exchange 2013

  24. Hi Satheshwaran,

    Does this work for 2013 SP1, too?

    Thanks,
    Steven

  25. Hi Satheshwaran Manoharan

    Your article was very helpful and i have the exact same issue which i am trying to resolve. Using the above command and process to recreate the exchange accounts i guess would need to be done out of hours and any other precautions that need to be done or to know. Would this bring the exchnage server down.

  26. I have a production 2010 exchange enviroment and a new tasking to search mailboxes for particular data. I dont have the system mailboxes in ADUC or exchange.
    I tried to run the setup.com/prepare ad on my exch server and dc.
    I am getting: The well-known object entry B:32:B3DDC6BE2A3BE84B97EB2DCE9477E389:CN=Help DeskADEL:324173d0-99c6-4437-9750-821aad8701ba on the otherWellKnownObjects attribute in the container object CN=Microsoft Exchange,CN=Services,CN=Configuration points to an invalid DN or a deleted object. Remove the entry, and then rerun the task.

    Have you seen this before?

  27. Hi,is there any effects if i move these accounts to another Database in Exchange server ?

  28. Hi Sathish,

    1.My Test-Mailflow results always failure in my Production Exchange .. i think my System mailbox Corrupted..
    if i run Setup.com /prepareAd will there be any impact on Production ??

  29. Hi,

    My Test-Mailflow results always failure in production . if in run setup.com /preparead will impact on production ??

  30. Satheshwaran Manoharan, you rock man.

    Your article post was in Jan 2012 and you still respond to posts over 3 1/2 years later! WOW dude.

    Good article BTW. I found it today for an issue I’m having. Keep up the good work!

  31. Hi,

    Thank you for posting such a very useful article. I Just need to confirm that should i run setup.com /PrepareAd on child domain controllers as well? because after successfully created arbitration users on forest domain i get error on enable-mailbox command that the xyz arbitration user not found on (mychilddomain).

  32. Thanks for this post Satheshwaran. I had to Disable and then Enable the discovery search because of some errors when I was trying to update to Exchange 2010 SP3. I ran the following and it all worked.

    Disable-Mailbox “DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}”

    Enable-Mailbox “DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}” -Arbitration

    Add-MailboxPermission -Identity:”cosp.internal/Users/DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}” -User:”Discovery Management” -AccessRights:”FullAccess”

    When I run Get-Mailbox -Arbitration I can see the discovery mailbox, however I cannot see this mailbox in the exchange management console, where I was able to see it before disabling/enabling. Also I see the discovery search mailbox in the disconnected mailbox list. Any idea how to get it back into the GUI or it doesnt matter? Thanks!

  33. Had a problem with corrupted system accounts caused “#550 5.2.0 Resolver.MT.NoArbitrationAddress; No arbitration address for approval process ##”

    As per the many sets of instruction I deleted the system accounts. When I run setup.com /preparead it says copying files and then stops. Never does the copy never recreates accounts. I checked the versions and both echange and the setup.com are the same 14.01.0270.001

    Any other fixes for setup not running?

    • Hi David Mickelson,
      were you able to solve your issue?

      I have the same problem:”When I run setup.com /preparead it says copying files and then stops. No accounts are created”

      Any feedback will be appreciated

      Thanks

  34. Thanks for the nice article. I am having a challenge were some of these accounts are pointing to my DR site when I run get-mailbox -arbitration:

    FederatedEmail.4c1f4d8..
    SystemMailbox{1f05a927..
    SystemMailbox{e0dc1c29..

    does it matter where they are pointing?

  35. Hi, great article!
    Thank you
    However, I have an exchange 2010 SP3 with Update Rollup 11.
    What media CD shall I use to launch the Setup.com /prepareAd?
    Can I only take the exchange 2010 SP3 media or must I take the latest version of setup.com coming with RU11?

    Thanks for the feedback

  36. Nice informative article, well presented and easy on the eye.
    My Exchange 2010 is a child in the forest, i might have (i did) deleted the first Mailbox and Arbitration mailboxes…..do i have to get my mates in HQ to run the Setup.com /prepareAd
    (in the root and with exchange forest admin rights)..or can i do it on our subdomain Exchange??

  37. You rock dude!!! I recently got a request to perform eDiscovery and noticed that the system mailboxes are missing but the discovery search mailbox is still present. I’m considering following the steps you’d provided but I have a few questions. Also, I just verified that I only have federateemail by running get-mailbox – arbitration.

    1. Do I run the command in my exchange server or domain controller?
    2. Do I use the exchange server DVD?
    3. What’s the impact in production? Is this an off-hour task or can it run during production hours?

    Thanks in advance.

  38. You rock dude!!! I recently got a request to perform eDiscovery and noticed that the system mailboxes are missing but the discovery search mailbox is still present. I’m considering following the steps you’d provided but I have a few questions. Also, I just verified that I only have federatedemail by running get-mailbox – arbitration.

    1. Do I run the command in my exchange server or domain controller?
    2. Do I use the exchange server DVD?
    3. What’s the impact in production? Is this an off-hour task or can it run during production hours?

    Thanks in advance.

    • Run on Schema master AD. if AD tools are installed in Exchange. and Exchange in Same site of Schema Master.
      Yes you can do it on exchange.
      Yes need Exchange setup files. same version you are running.
      no impact on production.

  39. Great!

    I had followed all step and my issue was resolved.

    Thanks for your support.

Leave a Reply

Your email address will not be published.